[Gfoss] [gdal-dev] [SOLVED] GDAL crashing on Ubuntu 8.10

Ciao: magari di interesse qua!

---------- Forwarded message ----------
From: Even Rouault <even.rouault@mines-paris.org>
Date: Wed, Mar 18, 2009 at 12:33 AM
Subject: [gdal-dev] [SOLVED] GDAL crashing on Ubuntu 8.10
To: gdal-dev@lists.osgeo.org

Hi all,

Several users have reported over the past few weeks various crashes when
running GDAL, in particular in OGRFeature::GetFieldAsString(). It has been
finally identified that it was due to stricter guard logic in GCC that was
enabled in Ubuntu 8.10 and later versions because -D_FORTIFY_SOURCE=2 is set
by default and is activated when -O is set to 2 or higher.
A similar issue was detected in DTEDDataset::CreateCopy() a few weeks ago and
was also fixed.

The fixes have been applied to current development version, 1.6 stable branch
and 1.5 branch. Please refer to http://trac.osgeo.org/gdal/ticket/2896 and
http://trac.osgeo.org/gdal/ticket/2824 if you need to apply the relevant
patches without waiting for next stable releases.

However, it might be possible that similar issues still remain, especially in
less popular drivers, so please report it.

Best regards,

gdal-dev mailing list