[Gfoss] Spatialite su Debian sid.

La versione 2.3 beta (a breve RC) e' disponibile sul repository debian-gis
e - ftpmaster permettendo - a breve in sid. Sono benvenute prove e quanto
altro per verificare che non ci siano problemi con feedback a me per il
packaging e ad Alessandro Furieri per tutto il resto :slight_smile:

--
Francesco P. Lovergine

Il giorno 16 marzo 2009 14.03, Francesco P. Lovergine <frankie@debian.org> ha scritto:

La versione 2.3 beta (a breve RC) e’ disponibile sul repository debian-gis
e - ftpmaster permettendo - a breve in sid. Sono benvenute prove e quanto
altro per verificare che non ci siano problemi con feedback a me per il
packaging e ad Alessandro Furieri per tutto il resto :slight_smile:


Francesco P. Lovergine

Ciao,
per repository intendi le svn? http://wiki.debian.org/DebianGis/Repository

da compilare con qmake?

r

On Mon, Mar 16, 2009 at 02:27:30PM +0100, Cassiel wrote:

Il giorno 16 marzo 2009 14.03, Francesco P. Lovergine
<frankie@debian.org>ha scritto:

> La versione 2.3 beta (a breve RC) e' disponibile sul repository debian-gis
> e - ftpmaster permettendo - a breve in sid. Sono benvenute prove e quanto
> altro per verificare che non ci siano problemi con feedback a me per il
> packaging e ad Alessandro Furieri per tutto il resto :slight_smile:
>
> --
> Francesco P. Lovergine

Ciao,
per repository intendi le svn? http://wiki.debian.org/DebianGis/Repository

da compilare con qmake?

No, intendo (al momento) il repository subversion. Il vecchio repository
non e' piu' operativo da un pezzo, si usa esclusivamente backports.org e l'archivio
standard di unstable per lo sviluppo. Chiaramente - sempre al momento - occorre
fare il build dai sorgenti.

svn co svn://svn.debian.org/svn/pkg-grass/packages/spatialite/trunk/debian

Il "per il momento" e' dovuto - come spiegato - ai tempi tecnici di approvazione
del nuovo package in sid.

http://ftp-master.debian.org/new/spatialite_2.3~beta1-1.html

--
Francesco P. Lovergine

Il giorno 16 marzo 2009 20.17, Francesco Paolo Lovergine <frankie@debian.org> ha scritto:

On Mon, Mar 16, 2009 at 02:27:30PM +0100, Cassiel wrote:

Il giorno 16 marzo 2009 14.03, Francesco P. Lovergine
<frankie@debian.org>ha scritto:

La versione 2.3 beta (a breve RC) e’ disponibile sul repository debian-gis
e - ftpmaster permettendo - a breve in sid. Sono benvenute prove e quanto
altro per verificare che non ci siano problemi con feedback a me per il
packaging e ad Alessandro Furieri per tutto il resto :slight_smile:


Francesco P. Lovergine

Ciao,
per repository intendi le svn? http://wiki.debian.org/DebianGis/Repository

da compilare con qmake?

No, intendo (al momento) il repository subversion. Il vecchio repository
non e’ piu’ operativo da un pezzo, si usa esclusivamente backports.org e l’archivio
standard di unstable per lo sviluppo. Chiaramente - sempre al momento - occorre
fare il build dai sorgenti.

svn co svn://svn.debian.org/svn/pkg-grass/packages/spatialite/trunk/debian

Il “per il momento” e’ dovuto - come spiegato - ai tempi tecnici di approvazione
del nuovo package in sid.

http://ftp-master.debian.org/new/spatialite_2.3~beta1-1.html


Francesco P. Lovergine

Ok, grazie, quindi si va di svn e dpkg-buildpackage.

Riguardo a gdal-ecw invece, utilizzate i sorgenti di ermapper e poi procedete con la ricompilazione delle gdal o lavorate allo sviluppo separato di un nuovo pacchetto?
Non ho ancora provato a ricompilare sulla nuova testing ma sulla vecchia la ricompilazine dei gdal-1.5.0 non andava a buon fine. Se avete qualche suggerimento ve ne sarei grato.

saluti
r

On Tue, Mar 17, 2009 at 10:02:40AM +0100, Cassiel wrote:

Ok, grazie, quindi si va di svn e dpkg-buildpackage.

Riguardo a gdal-ecw invece, utilizzate i sorgenti di ermapper e poi
procedete con la ricompilazione delle gdal o lavorate allo sviluppo separato
di un nuovo pacchetto?
Non ho ancora provato a ricompilare sulla nuova testing ma sulla vecchia la
ricompilazine dei gdal-1.5.0 non andava a buon fine. Se avete qualche
suggerimento ve ne sarei grato.

Esistono gia' due nuovi package completi di librerie ECW 3.3 e relativo plugin
per una plain 1.5.4 (prossimamente per 1.6.0 e 1.5.2, giusto per completare il supporto
di quanto attualmente distribuito fra lenny/squeeze/sid). Per plain intendo
proprio le librerie normalmente distribuite, cui il plugin si integra.
C'e' solo da mettere il tutto su debian.gfoss.it, cosa della quale si sta
occupando Nicco. A quel punto basta un apt-get install. Naturalmente
se ci si inca**a Erdas sono fattacci del presidente :stuck_out_tongue: ...

--
Francesco P. Lovergine

Il giorno 17 marzo 2009 17.47, Francesco P. Lovergine <frankie@debian.org> ha scritto:

On Tue, Mar 17, 2009 at 10:02:40AM +0100, Cassiel wrote:

Ok, grazie, quindi si va di svn e dpkg-buildpackage.

Riguardo a gdal-ecw invece, utilizzate i sorgenti di ermapper e poi
procedete con la ricompilazione delle gdal o lavorate allo sviluppo separato
di un nuovo pacchetto?
Non ho ancora provato a ricompilare sulla nuova testing ma sulla vecchia la
ricompilazine dei gdal-1.5.0 non andava a buon fine. Se avete qualche
suggerimento ve ne sarei grato.

Esistono gia’ due nuovi package completi di librerie ECW 3.3 e relativo plugin
per una plain 1.5.4 (prossimamente per 1.6.0 e 1.5.2, giusto per completare il supporto
di quanto attualmente distribuito fra lenny/squeeze/sid). Per plain intendo
proprio le librerie normalmente distribuite, cui il plugin si integra.
C’e’ solo da mettere il tutto su debian.gfoss.it, cosa della quale si sta
occupando Nicco. A quel punto basta un apt-get install. Naturalmente
se ci si inca**a Erdas sono fattacci del presidente :stuck_out_tongue:


Francesco P. Lovergine

Fantastico!
Nel frattempo ho tirato giù e compilato il plugin dai rep svn e per quanto riguarda le linee guida, la draft, che avete sul wiki
http://wiki.gfoss.it/index.php/Come_abilitare_il_supporto_ai_file_ECW_in_GDAL_e_visualizzarli_in_GRASS_e_QGIS

vi segnalo che ho provato su una lenny amd64 (su un server hp dual opteron) e alla stringa di configurazione è stato necessario aggiungere il path a gdal-config per la compilazione del plugin, pena l’interruzione del make:
./configure --with-ecw=/usr/local/libecw --with-autoload=/usr/lib/gdal15plugins --with-gdal=path_to_gdal_config

Non ho avuto problemi su una squeeze amd64 installata su un desktop amd64 dual core.

Se può esservi utile posso riprodurre l’errore e postarvi l’output.

r

ps: mi sembra che erdas sia tornata sui suoi passi riguardo la licenza.

No more restrictions on the distribution of ‘Server Software’ under the GPL-style Public Use License Agreement


Cassiel ha scritto:

ps: mi sembra che erdas sia tornata sui suoi passi riguardo la licenza.

    No more restrictions on the distribution of 'Server Software' under
    the GPL-style Public Use License Agreement

Questa e' una notiziona!
Dove l'hai presa?
--
Paolo Cavallini: http://www.faunalia.it/pc

E’ in calce alla pagina di download dei sorgenti delle libecw e dei binari.

r

Il giorno 18 marzo 2009 13.44, Paolo Cavallini <cavallini@faunalia.it> ha scritto:

Cassiel ha scritto:

ps: mi sembra che erdas sia tornata sui suoi passi riguardo la licenza.

No more restrictions on the distribution of ‘Server Software’ under
the GPL-style Public Use License Agreement

Questa e’ una notiziona!
Dove l’hai presa?

Paolo Cavallini: http://www.faunalia.it/pc

E’ questo:
http://www.ermapper.com/Products/ERDASProductInformation/tabid/84/currentid/1142/default.aspx

scusate ma pensavo fosse necessario essere registrati per vederlo

r

Il giorno 18 marzo 2009 14.00, Markus Neteler <neteler@osgeo.org> ha scritto:

Potresti mandare l’url alla lista (per evitare che tanti di
noi cercano la stessa cosa…)

grazie!
markus

On Wed, Mar 18, 2009 at 02:09:45PM +0100, Cassiel wrote:

E' questo:
http://www.ermapper.com/Products/ERDASProductInformation/tabid/84/currentid/1142/default.aspx

scusate ma pensavo fosse necessario essere registrati per vederlo

r

Il giorno 18 marzo 2009 14.00, Markus Neteler <neteler@osgeo.org> ha
scritto:

> Potresti mandare l'url alla lista (per evitare che tanti di
> noi cercano la stessa cosa...)
>
> grazie!
> markus
>

Non e' cambiata una virgola. La 3.3 ha sempre avuto quelle condizioni.
Rimane il fatto che GDAL non e' GPL e nemmeno Mapserver, il che rende
la presunta compatibilita' pressocche' inutile.

--
Francesco P. Lovergine

On Wed, Mar 18, 2009 at 01:21:01PM +0100, Cassiel wrote:

Fantastico!
Nel frattempo ho tirato giù e compilato il plugin dai rep svn e per quanto
riguarda le linee guida, la draft, che avete sul wiki
http://wiki.gfoss.it/index.php/Come_abilitare_il_supporto_ai_file_ECW_in_GDAL_e_visualizzarli_in_GRASS_e_QGIS

vi segnalo che ho provato su una lenny amd64 (su un server hp dual opteron)
e alla stringa di configurazione è stato necessario aggiungere il path a
gdal-config per la compilazione del plugin, pena l'interruzione del make:
./configure --with-ecw=/usr/local/libecw
--with-autoload=/usr/lib/gdal15plugins --with-gdal=path_to_gdal_config

Non ho avuto problemi su una squeeze amd64 installata su un desktop amd64
dual core.

Se può esservi utile posso riprodurre l'errore e postarvi l'output.

Considera che il plugin cui mi riferisco non e' derivato da quel repository.

--
Francesco P. Lovergine