[pgrouting-dev] Function Naming Issue


I am working on a new function to be added to pgRouting but cannot come up with a suitable name for it. It is a graph transformation function that converts a graph into a form that allows for a one to many dijkstra search with turn penalties and restrictions so I have called it pgr_turnPenaltyGraph but would like a better name. Following is a link to a stack-exchange question that I asked to see if anyone knows a formal name for this type of graph transformation. In this question you can see a rough description of the transformation and images that help visualize it. I have also added a link to the current documentation rst file. Please let me know if anyone has suggestions for naming this function or naming this graph transformation / if you have any questions about the function.

Stack Exchange Question:

Beta Documentation RST File:



Anthony Tasca