[pgrouting-dev] [SoC] Proposal for Chinese Postman Problem, pgRouting

Hi All,

Here is the first draft of my proposal. https://docs.google.com/document/d/1jShd4t3bqUfQhgWIbv8HLm9xYewZt4gRA_Ox47H1GuQ/edit?usp=sharing
I am considering how to improve it. It would be really appreciated if you could give me any suggestion. You can comment on my proposal directly. :slight_smile:

Thanks,

Maoguang Wang

Hi All,

I have changed something in “timeline” & “attention” section, because of the boost version issue.

Please review it if you have a moment. Thanks a lot.

Here is the link to my proposal:
https://docs.google.com/document/d/1jShd4t3bqUfQhgWIbv8HLm9xYewZt4gRA_Ox47H1GuQ/edit?usp=sharing

Best regards,

Maoguang Wang

···

On Wed, Mar 7, 2018 at 10:51 AM, Devrim Gündüz <devrim@gunduz.org> wrote:

Hi Vicky,

On Tue, 2018-03-06 at 10:59 -0600, Vicky Vergara wrote:

On the OSGeo code sprint I will make the release of pgROuting where I state
that the minimum version for boost graph is 1.53 instead of 1.46

There is this proposal of a student for the GSoC where he would need 1.55
for boost, as the minimum version.

If, the proposal is accepted, and if the student finishes his work on time,
then his code would go to the release we do on September.
Do you think that by September, 1.55 can be the minimum?

RHEL/CentOS 7 has 1.53 in the repos, so we will lose our main distro if you
update min version to 1.55.

Regards,


Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR