[SAC] [Webcom] Language issues on web site

Hi Angelos,
great to see this effort happen, no worries if things break, it can all be repaired. If you have suggestions how to improve the documentation please feel free to let this list know.

Cheers, Arnulf

Arnulf Christl (aka Seven)

----- Reply message -----
From: “Angelos Tzotsos” gcpp.kalxas@gmail.com
To: “Web Site Committee (WebCom) mailing list” webcom@lists.osgeo.org
Cc: “Seven (aka Arnulf)” seven@arnulf.us, “System Administration Committee Discussion/OSGeo” sac@lists.osgeo.org
Subject: [Webcom] Language issues on web site
Date: Thu, Jun 14, 2012 12:16

On 06/13/2012 05:49 PM, Seven (aka Arnulf) wrote:

Hash: SHA1

the translation in our current version of Drupal is not only confusing
but also seems to not work quite right.

Somebody translated the Charter Members [1] page to Greek (in general
a good idea) but instead of creating a “New Translation” overwrote the
English version. I reverted the edit and then tried to copy the Greek
version into the Greek node but Greek does not show up in the
translation tab?! But it does show up on the main languages list in
the left border.

TO see the results it also makes a difference if you are logged in or
not and what language settings are selected in the profile (if logged

User interface and content language switch:

  • When switching user interface language, switch also the content language
  • Keep separated user interface and content language
  • Use global options

Never quite got what these options are supposed to do either.

I have been struggling with all these “feature” since we have them and
never really got satisfying results. Probably I am too dumb to use
this correctly but if I am not significantly dumber than the rest of
the crew then statistically at least half of the potential
contributors will fail in the same way (after getting frustrated for
some time). This is inefficient. Ideas what we can do to change this?


[1] https://www.osgeo.org/charter_members

Exploring Space, Time and Mind
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Webcom mailing list

Hi Arnulf,

Thank you for picking up this issue. Alex also corrected a similar issue
a few days back.

Those errors are part of a translation project in Greek that the Greek
Chapter has started recently.
Unfortunately the translators are not expert users in drupal and this
has caused those issues. I am sorry for the inconvenience.
I will now hold this project until we have this issue/process figured out.

Best regards,

Angelos Tzotsos
Remote Sensing Laboratory
National Technical University of Athens